phpMyAdmin出现数据库错误:Warning in ./libraries/plugin_interface.lib.php#530….的解决方法

阿豪运维笔记 2021-01-17 1.15 K阅读

温馨提示:这篇文章已超过533天没有更新,请注意相关的内容是否还可用!

今天升级服务器环境的php版本到php7以上,打开phpmyadmin管理地址,导入数据库的时候提示报错如下

Warning in ./libraries/plugin_interface.lib.php#530

 count(): Parameter must be an array or an object that implements Countable

image.png

百度了下报错提示是因为phpmyadmin版本不兼容当前使用的php版本导致的。

phpMyAdmin版本对应php关系如下

PHP5.2版本请安装 phpmyadmin4.1。

PHP5.5版本及以下版本,请安装phpmyadmin4.4。

PHP7.1或者更高,请安装phpmyadmin4.7/4.8以上版本

解决办法

访问https://www.phpmyadmin.net/ phpmyadmin官网下载最新版本替换旧版本的phpmyadmin

替换后在访问phpmyadmin地址点击导入如下报错解决了

image.png

若文章图片、下载链接等信息出错,请联系反馈,博主将第一时间更新!如果喜欢本站,请打赏支持本站,谢谢!
文章版权声明:除非注明,否则均为阿豪运维笔记原创文章,转载或复制请以超链接形式并注明出处。

目录[+]

取消
微信二维码
微信二维码
支付宝二维码