本文作者:阿豪

购买云服务器后安装宝塔面板环境该如何选择

阿豪 6个月前 ( 12-12 ) 293
购买云服务器后安装宝塔面板环境该如何选择摘要: 宝塔面板系统介绍初次登入宝塔面板会提示让我们选择需要安装的环境,如LNMP(Linux/Nginx/Mysql/php/phpMyAdmin )或者LAMP(Linux/Apach...

宝塔面板系统介绍

初次登入宝塔面板会提示让我们选择需要安装的环境,如LNMP(Linux/Nginx/Mysql/php/phpMyAdmin )或者LAMP(Linux/Apache/Mysql/php/phpMyAdmin)

image.png

上图我们可以看到宝塔面板给大家推荐LNMP环境,为什么默认推荐LNMP而不推荐LAMP呢?因为Apache有些臃肿,内存和 CPU 开销大,性能上有损耗,不如一些轻量级的 Web 服务器,如Nginx是轻量级的 Web 服务器对于静态文件的响应能力来说远高于 Apache 服务器。至于安装哪个需要由程序来决定,如程序无特殊要求,推荐大家首选LNMP

Linux系统版本选择推荐

如果程序是php程序,推荐大家使用Linux系统,比如使用Centos系统,在阿里云和腾讯云平台能用最高版本或者次高版本就不要用老版本如Centos5/Centos6,追求稳定可以选择Centos7最新版本或者次高版本

环境版本选择

选择如上图推荐的LNMP环境

Nginx:选择最高版本,版本越高性能越好,一些漏洞Nginx官网也给予修复(或者选择Tengine ,Tengine是淘宝优化的版本);

Mysql:小内存服务器(低于2G)适合安装5.1/5.5版本。大于等于2G内存的服务器建议安装5.6版本,程序如果没有特殊需求,安装5.1或者5.5或者5.6都行,有特殊需求则选择对应版本即可(内存不够则升级);

Pure-Ftprd:默认版本即可(这个是FTP软件)

PHP:默认是推荐5.6(老程序如果不支持5.6可以选择更低的版本),Wordpress和Zblogphp版程序一般都是支持最新版本的,越高版本性能越好,PHP解析能力越强,如果服务器配置不高按照默认推荐的就可以了。

宝塔面板环境版本安装方式

极速安装:安装时间较快,一般用rpm或者yum安装,版本和稳定性略低适合测试环境使用。

编译安装,安装时间较长(服务器配置高低编译的时间也有差异),性能最大化,适合生产环境

短期测试优先选择极速安装,长期稳定运行则选择编译安装。

博客程序举例

1核2G的服务器配置安装Wordpress或者Zblogphp,选择Lnmp环境推荐的版本即可(PHP版本也可以选择PHP7.4,mysql版本选择5.5或者5.1)

2核4G的服务器配置可以选择Mysql5.5或者5.6(大于1核2G的配置不推荐使用Mysql5.1)

总结

安装LNMP的时候版本选新不选旧,追求稳定可以选择次高版本,Linux系统如Centos系统一般可以用好几年,总体来说选择最新版本或者次高版本,性能,安全性,稳定性等方面都比老版本更加可靠

文章版权及转载声明

作者:阿豪本文地址:https://www.ahaoyw.com/article/512.html发布于 6个月前 ( 12-12 )
文章转载或复制请以超链接形式并注明出处Ahao.Yw • 挨踢仔博客

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏